Refresh patches
[navit-package] / debian / patches / remove-ttf-liberation
index 220064f..be74146 100644 (file)
@@ -1,27 +1,31 @@
+Handles the removal of embedded ttf-liberation from upstream-svn.
 Index: navit/configure.in
 ===================================================================
---- navit.orig/configure.in    2009-02-20 21:03:42.000000000 +0100
-+++ navit/configure.in 2009-02-20 21:11:03.000000000 +0100
-@@ -836,7 +836,6 @@
+--- navit.orig/configure.in    2009-12-10 21:39:47.000000000 +0100
++++ navit/configure.in 2009-12-10 22:14:44.000000000 +0100
+@@ -825,7 +825,6 @@
  navit/fib-1.1/Makefile
  navit/font/Makefile
  navit/font/freetype/Makefile
 -navit/fonts/Makefile
  navit/graphics/Makefile
+ navit/graphics/android/Makefile
  navit/graphics/gd/Makefile
- navit/graphics/gtk_drawing_area/Makefile
 Index: navit/navit/Makefile.am
 ===================================================================
---- navit.orig/navit/Makefile.am       2009-02-20 21:11:12.000000000 +0100
-+++ navit/navit/Makefile.am    2009-02-20 21:11:17.000000000 +0100
-@@ -5,10 +5,6 @@
-   SUBDIRS += maps
+--- navit.orig/navit/Makefile.am       2009-12-10 21:39:47.000000000 +0100
++++ navit/navit/Makefile.am    2009-12-10 22:17:03.000000000 +0100
+@@ -4,12 +4,9 @@
+ if PLUGINS
+   SUBDIRS += .
  endif
+-DIST_SUBDIRS=binding map maptool fib-1.1 font fonts gui graphics osd speech support vehicle xpm maps
++DIST_SUBDIRS=binding map maptool fib-1.1 font gui graphics osd speech support vehicle xpm maps
+ SUBDIRS+=binding map font gui graphics osd speech vehicle xpm
  
 -if FONTS
 -  SUBDIRS += fonts
 -endif
--
- AM_CPPFLAGS = -I$(top_srcdir)/navit/fib-1.1 @NAVIT_CFLAGS@ @ZLIB_CFLAGS@ -DPREFIX=\"@prefix@\" -DLIBDIR=\"@libdir@\" -DMODULE=navit
- BUILT_SOURCES = version.h
- if BUILD_SAMPLEMAP
+ if !PLUGINS
+   SUBDIRS += .
+ endif