Adding a bunch of apps from diablo and garage
[oespirit1] / alarmd_0.5.20.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Cron like daemon functionality"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "base"
8 DEPENDS = "dbus dbus-glib glib-2.0 libconic osso-systemui-dbus-dev dsme mce-dev "
9 PR = "r0"
10
11 SRC_URI = "http://repository.maemo.org/pool/diablo/free/a/${PN}/${PN}_${PV}.tar.gz  \
12            file://alarmd-patches/mer-changes.patch;patch=1"
13
14
15 inherit autotools pkgconfig
16
17 PARALLEL_MAKE = ""
18 EXTRA_OEMAKE = "LIBTOOL=arm-${DISTRO}-linux-gnueabi-libtool"
19
20
21
22
23 do_configure_prepend(){
24     for i in `grep -l -r Werror *`;
25         do sed -i s:-Werror::g $i;
26     done
27 }
28
29
30 # FIXME Ugly hack follows
31 # Need to know why that file is created with
32 # 0 value for permisions
33 do_install_prepend(){
34     chmod --recursive 777 ${S}/.pc
35 }
36
37
38
39 do_install(){
40     install -d ${D}${bindir} ${D}${libdir} ${D}${includedir}  ${D}${libdir}/alarmd
41     install -m 0755 ${S}/.libs/alarmd ${D}${bindir}
42     install -m 0755 ${S}/.libs/alarmtool ${D}${bindir}
43     install -m 0755 ${S}/.libs/apitest ${D}${bindir}
44     install -m 0755 ${S}/.libs/dbustest ${D}${bindir}
45     oe_libinstall -so libalarm ${D}${libdir}
46     oe_libinstall -so libretu ${D}${libdir}/alarmd
47     oe_libinstall -so libgtimeout ${D}${libdir}/alarmd
48     install -m 0644 ${S}/include/*.h ${D}${includedir}
49 }
50
51 do_stage(){
52     install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}   
53     oe_libinstall -so libalarm    ${STAGING_LIBDIR}
54     oe_libinstall -so libretu     ${STAGING_LIBDIR}
55     oe_libinstall -so libgtimeout ${STAGING_LIBDIR}
56     install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}
57 }
58
59 PACKAGES += " alarmtool libalarm0"
60
61 #Keeping in tune with Maemo packaging
62 FILES_${PN} += "${libdir}/libretu.so \ 
63                 ${libdir}/libgtimeout.so"
64 FILES_alarmtool = "${bindir}/alarmtool"
65
66 FILES_libalarm  = "${libdir}/libalarm.so.*"
67
68