Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / hildon-angstrom-image.bb
1 GPE_EXTRA_THEMES = "gpe-theme-industrial"
2
3 GPE_EXTRA_INSTALL_none = ""
4 GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
5 GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
6
7 GUI_MACHINE_CLASS ?= "none"
8 GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
9
10 #ship more stuff with devices with >16MB of flash
11 GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
12     task-gpe-connectivity \
13     gpe-theme-clearlooks \
14     figment \
15 ",d)}'
16
17 GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
18
19 XSERVER ?= "xserver-kdrive-fbdev"
20
21 DEPENDS = "${MACHINE_TASK_PROVIDER} \
22            task-gpe-base \
23            task-gpe-apps \
24            task-gpe-pim \
25            task-gpe-settings \
26            task-gpe-games \
27            virtual/xserver"
28
29 PANGO_EXTRA_MODULES = " pango-module-arabic-fc \
30                         pango-module-arabic-lang \
31                         pango-module-basic-fc \
32                         pango-module-basic-x \
33                         pango-module-hangul-fc \
34                         pango-module-hebrew-fc \
35                         pango-module-indic-fc \
36                         pango-module-indic-lang \
37                         pango-module-khmer-fc \
38                         pango-module-syriac-fc \
39                         pango-module-thai-fc \
40                         pango-module-tibetan-fc "
41
42 MAEMO_L10N_PACKAGES  =  "   hildon-application-manager-l10n-public  \
43                             hildon-common-strings-l10n-public \
44                             hildon-control-panel-l10n-public \
45                             hildon-fm-l10n-public \
46                             hildon-input-method-l10n-public \
47                             hildon-libs-l10n-public \
48                             maemo-af-desktop-l10n-public \
49                             osso-applet-tasknavigator-l10n-public \
50                             osso-system-lock-l10n-public \
51                             osso-uri-l10n-public \
52                             osso-games-l10n-public  "
53
54 LIBPNG_MAEMO_PACKAGES = "libpng3 \
55                          libpng12 "
56
57
58 LOCALE_PACKAGES = " glibc-localedata-i18n \
59                     locale-base-en-gb"
60
61 DEBUG_PACKAGES =  " hildon-desktop-dbg \
62                     ltrace \
63                     gdb" 
64
65 TESTING_APPS =    "inotify-tools\ 
66                    maemopadplus \
67                    python-hildondesktop \
68                    hildon-desktop-python-loader \
69                    mobile-application-service "
70
71 IMAGE_INSTALL = "    ${MACHINE_TASK_PROVIDER} \
72     task-gpe-base \
73     task-gpe-pim \
74     task-gpe-settings \
75     task-gpe-apps \
76     ${XSERVER} \
77     ${GPE_EXTRA_INSTALL}\
78     x11vnc \
79     gconf \
80     gconf-dbus \
81     hildon-desktop \
82     ipkg \
83     osso-gnome-vfs2 \
84     osso-gnomevfs-extra \
85     screenshot-tool \
86     sapwood \
87     osso-af-utils \
88 # Fails at rootfs time, so temporarily removed
89 #   osso-af-settings \
90     marquee-plugins \
91     maemopad \
92     maemo-launcher \
93     matchbox \
94     matchbox-wm \
95     mobile-application-service \
96     pango \
97     libosso \
98     libhildonfm \
99     libhildonhelp \
100     libhildon \
101     libhildonmime \
102     libosso-gsf \
103     hildon-control-panel \
104     hildon-home-weather \
105     hildon-home-webshortcut \
106     hildon-icons \
107     hildon-notify \
108     hildon-plugins-settings \
109     hildon-thumbnail \
110     hildon-theme-tools \
111     hildon-theme-cacher \
112     hildon-theme-cacher \
113     hildon-theme-layout-4 \
114     hildon-theme-plankton \
115     gtkhtml3.14 \
116     clipboard-manager \
117     ${PANGO_EXTRA_MODULES} \
118     ${LIBPNG_MAEMO_PACKAGES} \
119     ${LOCALE_PACKAGES} \
120     ${MAEMO_L10N_PACKAGES} \
121     ${TESTING_APPS} \
122     ${DEBUG_PACKAGES} "
123
124 #ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
125
126 inherit image