Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / hildon-home-webshortcut_svn.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Webshortcut plugin for hildon home"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "x11"
8 DEPENDS = "libhildon libosso libconic libhildonfm hildon-desktop osso-af-settings"
9 PR = "r3"
10
11 SRC_URI = "svn://stage.maemo.org/svn/maemo/projects/haf/trunk;module=hildon-home-webshortcut;rev=18844;proto=https"
12
13 S = "${WORKDIR}/hildon-home-webshortcut"
14
15 inherit autotools pkgconfig
16
17 do_configure_prepend(){
18     for i in `grep -r -l Werror *`;
19         do sed -i s:-Werror::g $i;
20     done
21 }
22
23
24 FILES_${PN}  += "${libdir}/hildon-desktop/*"