Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / hildon-plugins-settings_0.0.10.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Applets to control the hildon desktop plugins"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "x11"
8 DEPENDS = "libosso osso-af-settings hildon-control-panel hildon-desktop libhildon dbus-glib libhildonhelp"
9 PR = "r1"
10
11 SRC_URI = "http://repository.maemo.org/pool/diablo/free/h/${PN}/${PN}_${PV}-1.tar.gz  \
12            file://hildon-plugins-settings/mer-changes.patch;patch=1"
13
14 inherit autotools pkgconfig
15
16 # A test workaround to fix the "No GNU_HASH"
17 # in elf binary issue            
18 TARGET_CC_ARCH += "${LDFLAGS}"
19
20 FILES_${PN} += "/usr/lib/hildon-control-panel/*"
21
22
23 do_stage(){
24     autotools_stage_all
25 }
26
27