Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / icd2-osso-ic_2.0.bb
1 # Copyright (C) 2009 Kirtika B Ruchandani <kirtibr@gmail.com> 
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Headers needed for libconic"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1 "
7 SECTION = "base"
8 DEPENDS = "dbus gconf"
9 PR = "r1"
10
11 SRC_URI = "http://repository.maemo.org/pool/diablo/free/i/${PN}-dev/${PN}-dev_${PV}.tar.gz"
12
13 inherit autotools pkgconfig
14
15 S = "${WORKDIR}/${PN}-dev-${PV}"
16     
17
18 do_configure_prepend() {
19  #Horrible hack follows. The dpkg-parsechangelog
20   #command in the first line used in AC_INIT breaks thing
21   #so do a manual replacement of that line
22   sed -i '1,2d' configure.ac
23   sed -i '1i AC_INIT([${PN}],[${PV}])' configure.ac
24
25 }
26
27 do_stage(){
28     autotools_stage_all
29 }
30
31
32
33