Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / libconic_0.19.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Nokia internet connectivity library"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "base"
8 DEPENDS = "dbus gconf icd2-osso-ic"
9 PR = "r3"
10
11 SRC_URI = "http://repository.maemo.org/pool/diablo/free/libc/${PN}/${PN}_${PV}.tar.gz"
12
13 inherit autotools pkgconfig
14
15 do_configure_prepend(){
16     #Remove all Werror flags
17     sed -i s:-Werror::g configure.ac
18     sed -i s:-Werror::g tests/Makefile.am
19        
20     #Horrible hack follows. The dpkg-parsechangelog
21     #command in the first line used in AC_INIT breaks thing
22     #so do a manual replacement of that line
23     sed -i '1,2d' configure.ac
24     sed -i '1i AC_INIT([${PN}],[${PV}])' configure.ac
25
26 }
27
28 do_stage() {
29         autotools_stage_all
30 }
31