Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / libhildonmime_2.1.3.bb
1 # Copyright (C) 2009 Unknow User <unknow@user.org>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4
5 DESCRIPTION = "Nokia Hildon mime library"
6 HOMEPAGE = "http://maemo.org"
7 LICENSE = "GNU Lesser General Public License-version 2.1"
8 SECTION = "base"
9 DEPENDS = "libosso gnome-vfs"
10 PR = "r1"
11
12 SRC_URI =  " http://repository.maemo.org/pool/maemo5.0beta/free/libh/${PN}/${PN}_${PV}-1+0m5.tar.gz \
13              file://libhildonmime/mer-changes.patch;patch=1 "
14
15 EXTRA_OECONF += "--with-compile-warnings=no"
16
17 inherit autotools pkgconfig lib_package
18
19 do_configure_prepend() {
20         # remove Werror from OSSO_CFLAGS
21         sed -i s:-Werror::g configure.in
22 }
23
24 do_stage() {
25         autotools_stage_all
26 }