Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / libpng3_1.2.35.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Libpng used by Maemo"
5 HOMEPAGE = "http://www.libpng.org/pub/png/libpng.html"
6 LICENSE = "unknown"
7 SECTION = "libs"
8 DEPENDS = "zlib"
9 PR = "r1"
10
11 SRC_URI = "http://repository.maemo.org/pool/maemo5.0beta/free/libp/${PN}/${PN}_${PV}-1maemo1.tar.gz"
12
13 require libpng.inc
14
15 do_stage() {
16         cp libpng.pc libpng12.pc
17         install -m 644 png.h ${STAGING_INCDIR}/png.h
18         install -m 644 pngconf.h ${STAGING_INCDIR}/pngconf.h
19         oe_libinstall -so libpng ${STAGING_LIBDIR}/
20         oe_libinstall -so libpng12 ${STAGING_LIBDIR}/
21         ln -sf libpng12.so ${STAGING_LIBDIR}/libpng.so
22 }
23
24 do_rm_work(){
25     :
26 }
27
28
29
30
31
32