Update the changelog
[opencv] / debian / rules
index b10665a..3a6812d 100644 (file)
@@ -24,14 +24,13 @@ endif
 
 config.status: configure
        dh_testdir
-       QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
        touch configure.in
        touch aclocal.m4
        touch configure
        touch cvconfig.h.in
        touch `find . -name Makefile.in`
        touch stamp-h.in
-       CFLAGS="$(CFLAGS)" ./configure $(confflags) --enable-static --enable-python --with-apps
+       CFLAGS="$(CFLAGS)" ./configure $(confflags) --enable-static --without-python --with-apps
 
 build: build-stamp
 build-stamp: config.status
@@ -45,7 +44,6 @@ clean:
        rm -f build-stamp 
        -$(MAKE) distclean
        rm -f tests/cv/src/lt-cvtest.lst tests/cv/src/lt-cvtest.sum
-       QUILT_PATCHES=debian/patches quilt pop -a -R || test $$? = 2
        dh_clean 
 
 install: build
@@ -69,10 +67,8 @@ binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs -i ChangeLog
-       dh_installdocs -i AUTHORS THANKS TODO debian/README.Debian
-       dh_installexamples -p opencv-doc samples/c/*.c samples/c/*.png samples/c/*.jpg samples/c/Makefile.debian
-       mv debian/opencv-doc/usr/share/doc/opencv-doc/examples/Makefile.debian debian/opencv-doc/usr/share/doc/opencv-doc/examples/Makefile
-       (cd debian/opencv-doc/usr/share/doc/opencv-doc/examples/python/; cp minidemo.py tmp ; echo '#!/usr/bin/python' >| minidemo.py ; cat tmp >> minidemo.py ; rm -f tmp)
+       dh_installdocs -i AUTHORS THANKS TODO
+       dh_installexamples -p opencv-doc samples/c/*.c samples/c/*.png samples/c/*.jpg
        #dh_install -p opencv-doc docs/*.rtf usr/share/doc/opencv-doc
        #dh_install -p opencv-doc docs/*.pdf usr/share/doc/opencv-doc
        #dh_install -p opencv-doc docs/*.htm usr/share/doc/opencv-doc/html
@@ -106,7 +102,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs -a ChangeLog
-       dh_installdocs -a AUTHORS THANKS TODO debian/README.Debian
+       dh_installdocs -a AUTHORS THANKS TODO
        dh_installexamples -a
 #      dh_install
 #      dh_installmenu
@@ -124,7 +120,6 @@ binary-arch: build install
        dh_compress -a
        dh_fixperms -a
 #      dh_perl
-       dh_pysupport -a
        dh_makeshlibs
        dh_installdeb -a
        dh_shlibdeps -a