Update the trunk to the OpenCV's CVS (2008-07-14)
[opencv] / tests / python / Makefile.am
index 52f9bd0..3734fba 100644 (file)
@@ -102,4 +102,11 @@ TESTS_ENVIRONMENT = \
     DYLD_LIBRARY_PATH=$(top_builddir)/cxcore/src/.libs:$(top_builddir)/cv/src/.libs:$(top_builddir)/otherlibs/highgui/.libs:$(LD_LIBRARY_PATH) \
     PYTHONPATH=$(top_srcdir)/interfaces/swig:$(top_builddir)/interfaces/swig/python/.libs
 
+# do tests only if we ask for python
+
+if BUILD_PYTHON_WRAPPERS
+
 TESTS = $(check_SCRIPTS)
+
+endif
+