Debian lenny version packages
[pkg-perl] / deb-src / libarray-compare-perl / libarray-compare-perl-1.16 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 #export DH_COMPAT=4
10
11 PACKAGE=$(shell dh_listpackages)
12
13 ifndef PERL
14 PERL = /usr/bin/perl
15 endif
16
17 build: build-stamp
18 build-stamp:
19         dh_testdir
20         # Add here commands to compile the package.
21         $(PERL) Build.PL installdirs=vendor create_packlist=0
22         ./Build
23         ./Build test
24         touch $@
25
26 clean:
27         dh_testdir
28         dh_testroot
29         dh_clean build-stamp install-stamp
30         [ ! -f Build ] || ./Build distclean
31
32 install: install-stamp
33 install-stamp: build-stamp
34         dh_testdir
35         dh_testroot
36         dh_clean -k
37         ./Build install destdir=$(CURDIR)/debian/$(PACKAGE)
38         #[ ! -d $(CURDIR)/debian/$(PACKAGE)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(CURDIR)/debian/$(PACKAGE)/usr/lib/perl5
39         touch $@
40
41 binary-arch:;
42 binary-indep: build install
43         dh_testdir
44         dh_testroot
45         dh_installdocs
46         dh_installchangelogs Changes
47         dh_compress
48         dh_fixperms
49         dh_installdeb
50         dh_perl
51         dh_gencontrol
52         dh_md5sums
53         dh_builddeb
54
55 binary: binary-indep binary-arch
56 .PHONY: build clean binary-indep binary-arch binary install configure