Modified source files and compiled any and armel versions of packages
[pkg-perl] / deb-src / libtest-perl-critic-perl / libtest-perl-critic-perl-1.01 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6 #
7 # It was later modified by Jason Kohles <email@jasonkohles.com>
8 # http://www.jasonkohles.com/ to support Module::Build installed modules
9
10 # Uncomment this to turn on verbose mode.
11 #export DH_VERBOSE=1
12
13 # If set to a true value then MakeMaker's prompt function will
14 # always return the default without waiting for user input.
15 export PERL_MM_USE_DEFAULT=1
16
17 PACKAGE=$(shell dh_listpackages)
18
19 ifndef PERL
20 PERL = /usr/bin/perl
21 endif
22
23 TMP     =$(CURDIR)/debian/$(PACKAGE)
24
25 build: build-stamp
26 build-stamp:
27         dh_testdir
28
29         # Add commands to compile the package here
30         $(PERL) Build.PL installdirs=vendor
31         $(PERL) Build
32         $(PERL) Build test
33
34         touch $@
35
36 clean:
37         dh_testdir
38         dh_testroot
39
40         dh_clean build-stamp install-stamp
41
42         # Add commands to clean up after the build process here
43         [ ! -f Build ] || $(PERL) Build distclean
44
45 install: install-stamp
46 install-stamp: build-stamp
47         dh_testdir
48         dh_testroot
49         dh_clean -k
50
51         # Add commands to install the package into debian/$PACKAGE_NAME here
52         $(PERL) Build install destdir=$(TMP) create_packlist=0
53
54         touch $@
55
56 binary-arch:
57 # We have nothing to do here for an architecture-independent package
58
59 binary-indep: build install
60         dh_testdir
61         dh_testroot
62         dh_installdocs README
63         dh_installexamples
64         dh_installchangelogs Changes
65         dh_perl
66         dh_compress
67         dh_fixperms
68         dh_installdeb
69         dh_gencontrol
70         dh_md5sums
71         dh_builddeb
72
73 source diff:
74         @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
75
76 binary: binary-indep binary-arch
77 .PHONY: build clean binary-indep binary-arch binary