Add the following packages libalgorithm-diff-perl libspiffy-perl libtext-diff-perl...
[pkg-perl] / deb-src / libtext-diff-perl / libtext-diff-perl-0.35 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 # export DH_COMPAT=4
10
11 PACKAGE=`pwd | sed -e "s/.*\/\\(.*\\)-.*/\\1/"`
12
13
14 build:
15         dh_testdir
16         # Add here commands to compile the package.
17         perl Makefile.PL verbose INSTALLDIRS=vendor
18 clean:
19         dh_testdir
20         dh_testroot
21
22         [ ! -f Makefile ] || $(MAKE) distclean
23         rm -f Makefile.old
24         dh_clean
25
26 install:
27         dh_testdir
28         dh_testroot
29         dh_clean -k
30         dh_installdirs
31
32         $(MAKE) PREFIX=$(CURDIR)/debian/$(PACKAGE)/usr OPTIMIZE="-O2 -g -Wall" test install
33         [ ! -d $(CURDIR)/debian/$(shell dh_listpackages)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(CURDIR)/debian/$(shell dh_listpackages)/usr/lib/perl5
34
35 binary-arch:;
36 binary-indep: build install
37         dh_testdir
38         dh_testroot
39         dh_installdocs
40         dh_installman
41         dh_installchangelogs Changes
42         dh_link
43         dh_strip
44         dh_compress
45         dh_fixperms
46         dh_installdeb
47         dh_perl
48         dh_gencontrol
49         dh_md5sums
50         dh_builddeb
51
52 binary: binary-indep binary-arch
53 .PHONY: build clean binary-indep binary-arch binary install configure