update about dialog
[presencevnc] / libvnc / LibVNCServer.spec
1 # Note that this is NOT a relocatable package
2 Name: LibVNCServer
3 Version: 0.9.7
4 Release: 2
5 Summary: a library to make writing a vnc server easy
6 Copyright: GPL
7 Group: Libraries/Network
8 Packager: Johannes.Schindelin <Johannes.Schindelin@gmx.de>
9 Source: %{name}-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
11
12 %description
13 LibVNCServer makes writing a VNC server (or more correctly, a program
14 exporting a framebuffer via the Remote Frame Buffer protocol) easy.
15
16 It is based on OSXvnc, which in turn is based on the original Xvnc by
17 ORL, later AT&T research labs in UK.
18
19 It hides the programmer from the tedious task of managing clients and
20 compression schemata.
21
22 LibVNCServer was put together and is (actively ;-) maintained by
23 Johannes Schindelin <Johannes.Schindelin@gmx.de>
24
25 %package devel
26 Requires:     %{name} = %{version}
27 Summary:      Static Libraries and Header Files for LibVNCServer
28 Group:        Libraries/Network
29 Requires:     %{name} = %{version}
30
31 %description devel
32 Static Libraries and Header Files for LibVNCServer.
33
34 %package x11vnc
35 Requires:     %{name} = %{version}
36 Summary:      VNC server for the current X11 session
37 Group:        User Interface/X
38 Requires:     %{name} = %{version}
39
40 %description x11vnc
41 x11vnc is to X Window System what WinVNC is to Windows, i.e. a server
42 which serves the current X Window System desktop via RFB (VNC)
43 protocol to the user.
44
45 Based on the ideas of x0rfbserver and on LibVNCServer, it has evolved
46 into a versatile and performant while still easy to use program.
47
48 %prep
49 %setup -n %{name}-%{version}
50
51 %build
52 # CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
53 %configure
54 make
55
56 %install
57 [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
58 # make install prefix=%{buildroot}%{_prefix}
59 %makeinstall includedir="%{buildroot}%{_includedir}/rfb"
60
61 %{__install} -d -m0755 %{buildroot}%{_datadir}/x11vnc/classes
62 %{__install} classes/VncViewer.jar classes/index.vnc \
63   %{buildroot}%{_datadir}/x11vnc/classes
64
65 %clean
66 [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
67
68 %pre
69 %post
70 %preun
71 %postun
72
73 %files
74 %defattr(-,root,root)
75 %doc README INSTALL AUTHORS ChangeLog NEWS TODO 
76 %{_bindir}/LinuxVNC
77 %{_bindir}/libvncserver-config
78 %{_libdir}/libvncclient.*
79 %{_libdir}/libvncserver.*
80
81 %files devel
82 %defattr(-,root,root)
83 %{_includedir}/rfb/*
84
85 %files x11vnc
86 %defattr(-,root,root)
87 %{_bindir}/x11vnc
88 %{_mandir}/man1/x11vnc.1*
89 %{_datadir}/x11vnc/classes
90
91 %changelog
92 * Fri Aug 19 2005 Alberto Lusiani <alusiani@gmail.com> release 2
93 - create separate package for x11vnc to prevent conflicts with x11vnc rpm
94 - create devel package, needed to compile but not needed for running
95 * Sun Feb 9 2003 Johannes Schindelin
96 - created libvncserver.spec.in
97