added libvnc/ with RealVNC compatibility fix
[presencevnc] / debian / rules
index e74f5cf..0af3df8 100755 (executable)
@@ -29,6 +29,9 @@ clean:
        dh_testroot
        rm -f build
        [ ! -f Makefile ] || $(MAKE) clean
+ifdef buildlibs
+       [ ! -f libvnc/Makefile ] || cd libvnc && make clean
+endif
        dh_clean
        rm -rf ${BUILDDIR}
 
@@ -43,7 +46,7 @@ binary-arch: build install
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps -l debian/presencevnc/${RESDIR}
+       LD_LIBRARY_PATH=debian/presencevnc/${RESDIR} dh_shlibdeps -l debian/presencevnc/${RESDIR}
        dh_gencontrol
        dh_md5sums
        dh_builddeb