release 0.6
[presencevnc] / debian / rules
index 64af44d..25b70af 100755 (executable)
@@ -5,7 +5,7 @@ export DH_VERBOSE=1
 #currently builds a maemo-only package
 
 #comment this line for quick builds
-#buildlibs=foo
+buildlibs=foo
 
 SOURCEDIR=./
 BUILDDIR=debian/build/
@@ -29,6 +29,9 @@ clean:
        dh_testroot
        rm -f build
        [ ! -f Makefile ] || $(MAKE) clean
+ifdef buildlibs
+       [ ! -f libvnc/Makefile ] || ( cd libvnc && make clean )
+endif
        dh_clean
        rm -rf ${BUILDDIR}
 
@@ -43,7 +46,7 @@ binary-arch: build install
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps -l debian/presencevnc/${RESDIR}
+       LD_LIBRARY_PATH=debian/presencevnc/${RESDIR} dh_shlibdeps -l debian/presencevnc/${RESDIR}
        dh_gencontrol
        dh_md5sums
        dh_builddeb