only build libvncclient instead of the whole library
[presencevnc] / debian / rules
index 0af3df8..eac9b67 100755 (executable)
@@ -5,7 +5,7 @@ export DH_VERBOSE=1
 #currently builds a maemo-only package
 
 #comment this line for quick builds
-buildlibs=foo
+#buildlibs=foo
 
 SOURCEDIR=./
 BUILDDIR=debian/build/
@@ -18,7 +18,7 @@ build:
        dh_testdir
        install -d ${BUILDDIR}
 ifdef buildlibs
-       cd libvnc && ./configure && make
+       cd libvnc && ./configure && cd libvncclient && make
 endif
        qmake-qt4 -after "DESTDIR=debian/build"
        $(MAKE)
@@ -30,7 +30,7 @@ clean:
        rm -f build
        [ ! -f Makefile ] || $(MAKE) clean
 ifdef buildlibs
-       [ ! -f libvnc/Makefile ] || cd libvnc && make clean
+       [ ! -f libvnc/Makefile ] || ( cd libvnc && make clean )
 endif
        dh_clean
        rm -rf ${BUILDDIR}