only build libvncclient instead of the whole library
[presencevnc] / debian / rules
index 64af44d..eac9b67 100755 (executable)
@@ -18,7 +18,7 @@ build:
        dh_testdir
        install -d ${BUILDDIR}
 ifdef buildlibs
-       cd libvnc && ./configure && make
+       cd libvnc && ./configure && cd libvncclient && make
 endif
        qmake-qt4 -after "DESTDIR=debian/build"
        $(MAKE)
@@ -29,6 +29,9 @@ clean:
        dh_testroot
        rm -f build
        [ ! -f Makefile ] || $(MAKE) clean
+ifdef buildlibs
+       [ ! -f libvnc/Makefile ] || ( cd libvnc && make clean )
+endif
        dh_clean
        rm -rf ${BUILDDIR}
 
@@ -43,7 +46,7 @@ binary-arch: build install
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps -l debian/presencevnc/${RESDIR}
+       LD_LIBRARY_PATH=debian/presencevnc/${RESDIR} dh_shlibdeps -l debian/presencevnc/${RESDIR}
        dh_gencontrol
        dh_md5sums
        dh_builddeb