initial import for sdlhaa & sdlhim
[sdlhildon] / sdlhim / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 CFLAGS = -Wall -g
13
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15         CFLAGS += -O0
16 else
17         CFLAGS += -O2
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22         dh_testdir
23         touch configure-stamp
24
25
26 build: build-stamp
27 build-stamp: configure-stamp 
28         dh_testdir
29
30         $(MAKE) CFLAGS="$(CFLAGS)"
31
32         touch $@
33
34 clean:
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp configure-stamp
38
39         -$(MAKE) clean
40
41         dh_clean 
42
43 install: build
44         dh_testdir
45         dh_testroot
46         dh_clean -k 
47         dh_installdirs
48
49         $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
50
51
52 # Build architecture-independent files here.
53 binary-indep: build install
54 # We have nothing to do by default.
55
56 # Build architecture-dependent files here.
57 binary-arch: build install
58         dh_testdir
59         dh_testroot
60         dh_installchangelogs 
61         dh_installdocs
62         dh_installexamples
63         dh_install --sourcedir=debian/tmp
64         dh_installman
65         dh_link
66         dh_strip
67         dh_compress
68         dh_fixperms
69         dh_makeshlibs -V "libsdl-him1.2-1 (>= 1.0.0)"
70         dh_installdeb
71         dh_shlibdeps
72         dh_gencontrol
73         dh_md5sums
74         dh_builddeb
75
76 binary: binary-indep binary-arch
77 .PHONY: build clean binary-indep binary-arch binary install configure