Initial commit (based on data-sharing-plugin)
[sharing-cli] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..f79d74c
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# This file is part of sharing-plugin-template
+#
+# Copyright (C) 2008-2009 Nokia Corporation. All rights reserved.
+#
+# This maemo code example is licensed under a MIT-style license,
+# that can be found in the file called "COPYING" in the root
+# directory.
+#
+
+plugins_LTLIBRARIES = libtemplate.la
+
+libtemplate_la_SOURCES = plugin.c common.c send.c validate.c
+
+libtemplate_la_CFLAGS = $(PACKAGE_CFLAGS) $(DEBUG_CFLAGS)
+libtemplate_la_LDFLAGS = -module -avoid-version -export-dynamic
+libtemplate_la_LIBADD = $(PACKAGE_LIBS)
+
+
+MAINTAINERCLEANFILES = Makefile.in
+
+