fixed named in xml
[shermanaquarium] / sherman-aquarium / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17
18
19 CFLAGS = -Wall -g
20
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22         CFLAGS += -O0
23 else
24         CFLAGS += -O2
25 endif
26
27 config.status: configure
28         dh_testdir
29         # Add here commands to configure the package.
30         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" 
31
32
33 build: build-stamp
34
35 build-stamp:  config.status
36         dh_testdir
37
38
39         touch $@
40
41 clean:
42         dh_testdir
43         dh_testroot
44         rm -f build-stamp 
45
46         # Add here commands to clean up after the build process.
47         -$(MAKE) distclean
48 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
49         cp -f /usr/share/misc/config.sub config.sub
50 endif
51 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
52         cp -f /usr/share/misc/config.guess config.guess
53 endif
54
55
56         dh_clean 
57
58 install: build
59         dh_testdir
60         dh_testroot
61         dh_clean -k 
62         dh_installdirs
63
64         $(MAKE) DESTDIR=$(CURDIR)/debian/shermans-aquarium install
65
66
67 # Build architecture-independent files here.
68 binary-indep: build install
69 # We have nothing to do by default.
70
71 # Build architecture-dependent files here.
72 binary-arch: build install
73         dh_testdir
74         dh_testroot
75         dh_installchangelogs ChangeLog
76         dh_installdocs
77         dh_installexamples
78 #       dh_install
79 #       dh_installmenu
80 #       dh_installdebconf       
81 #       dh_installlogrotate
82 #       dh_installemacsen
83 #       dh_installpam
84 #       dh_installmime
85 #       dh_python
86 #       dh_installinit
87 #       dh_installcron
88 #       dh_installinfo
89         dh_installman
90         dh_link
91         dh_strip
92         dh_compress
93         mkdir -p debian/shermans-aquarium/usr/share/livewp/external_themes/
94         cp debian/sherman.xml debian/shermans-aquarium/usr/share/livewp/external_themes/
95         mkdir -p debian/shermans-aquarium/usr/share/livewp/external_icons/
96         cp debian/sherman.png debian/shermans-aquarium/usr/share/livewp/external_icons/
97         cp debian/shermand.png debian/shermans-aquarium/usr/share/livewp/external_icons/
98         dh_fixperms
99 #       dh_perl
100 #       dh_makeshlibs
101         dh_installdeb
102         dh_shlibdeps
103         dh_gencontrol
104         maemo-optify
105         dh_md5sums
106         dh_builddeb
107
108 binary: binary-indep binary-arch
109 .PHONY: build clean binary-indep binary-arch binary install