Release version 0.7-0
[vicar] / qtc_packaging / debian_fremantle / rules
index 46da245..1278b97 100755 (executable)
@@ -9,36 +9,31 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+APPNAME := vicar
+builddir:
+       mkdir -p builddir
 
-
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # qmake PREFIX=/usr# Uncomment this line for use without Qt Creator
-
-       touch configure-stamp
-
+builddir/Makefile: builddir
+       cd builddir && qmake ../$(APPNAME).pro
 
 build: build-stamp
 
-build-stamp: configure-stamp  
+build-stamp: builddir/Makefile
        dh_testdir
 
        # Add here commands to compile the package.
-       # $(MAKE) # Uncomment this line for use without Qt Creator
-       #docbook-to-man debian/vicar.sgml > vicar.1
+       cd builddir && $(MAKE)
+       #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
 
        touch $@
 
-clean: 
+clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
+       rm -rf builddir
 
        dh_clean 
 
@@ -48,8 +43,8 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/vicar.
-       $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/vicar install
+       # Add here commands to install the package into debian/arora.
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
 
 
 # Build architecture-independent files here.
@@ -62,7 +57,7 @@ binary-arch: build install
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
-       dh_installexamples
+#      dh_installexamples
 #      dh_install
 #      dh_installmenu
 #      dh_installdebconf       
@@ -74,15 +69,15 @@ binary-arch: build install
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
-       dh_installman
+#      dh_installman
        dh_link
-       dh_strip
+       dh_strip #Uncomment to remove debug symbols
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
-       # dh_shlibdeps # Uncomment this line for use without Qt Creator
+       dh_shlibdeps # Uncomment this line for use without Qt Creator
        dh_gencontrol
        dh_md5sums
        dh_builddeb