fixed erronous gconf path in postins script (thanks to hutchinsfairy)
[wifi-assistant] / package / debian / wifi-assistant.postinst
1 #!/bin/sh
2
3 set -e
4
5 # TODO: write a proper update script that moves settings from old layout to new
6
7 # remove any old settings (perhaps a bad idea, especially with reinstall)
8 # gconftool-2 --recursive-unset /apps/maemo/wifi-assistant
9 # gconftool-2 --recursive-unset /apps/maemo/wifi_assistant
10
11 # set default settings' values
12 gconftool-2 -s /apps/maemo/wifi_assistant/daemon "true" --type boolean
13
14 # Hacky fix for NB#136012
15 gconftool-2 -s /desktop/gnome/url-handlers/http/command 'dbus-send --type=method_call --dest=com.nokia.osso_browser /com/nokia/osso_browser com.nokia.osso_browser.load_url string:"%s"' --type string 
16
17 # update icon cache
18 gtk-update-icon-cache -f /usr/share/icons/hicolor
19
20 # start daemon
21 /sbin/initctl stop wifi-assistant
22 /sbin/initctl start wifi-assistant