added initctl calls (should add an uninstall script too)
[wifi-assistant] / package / debian / wifi-assistant.postinst
1 #!/bin/sh
2
3 set -e
4 gconftool-2 -s /apps/maemo/wifi-assistant/url_to_open "http://wifi-assistant.garage.maemo.org/" --type string
5 gconftool-2 -s /apps/maemo/wifi-assistant/popup "true" --type boolean
6
7 # Hacky fix for NB#136012
8 gconftool-2 -s /desktop/gnome/url-handlers/http/command 'dbus-send --type=method_call --dest=com.nokia.osso_browser /com/nokia/osso_browser com.nokia.osso_browser.load_url string:"%s"' --type string 
9
10 # update icon cache
11 gtk-update-icon-cache -f /usr/share/icons/hicolor
12
13 # start daemon
14 /sbin/initctl stop wifi-assistant
15 /sbin/initctl start wifi-assistant