Easy Chroot 0.3.1
[easy-deb-chroot] / fremantle / easy-chroot / .py2deb_build_folder / easy-chroot / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 CFLAGS = -Wall -g
13
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15         CFLAGS += -O0
16 else
17         CFLAGS += -O2
18 endif
19
20 configure: configure-stamp
21 configure-stamp:
22         dh_testdir
23         # Add here commands to configure the package.
24
25         touch configure-stamp
26
27 build: build-stamp
28
29 build-stamp: configure-stamp
30         dh_testdir
31         touch build-stamp
32
33 clean:
34         dh_testdir
35         dh_testroot
36         rm -f build-stamp configure-stamp
37         dh_clean
38
39 install: build
40         dh_testdir
41         dh_testroot
42         dh_clean -k
43         dh_installdirs
44
45         # ======================================================
46         #$(MAKE) DESTDIR="$(CURDIR)/debian/easy-chroot" install
47         mkdir -p "$(CURDIR)/debian/easy-chroot"
48
49 #       mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
50         cp -a "src/sbin/closechroot" "$(CURDIR)/debian/easy-chroot/sbin/closechroot"
51         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
52         cp -a "src/sbin/cpu-ondemand" "$(CURDIR)/debian/easy-chroot/sbin/cpu-ondemand"
53         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
54         cp -a "src/sbin/cpu-perform" "$(CURDIR)/debian/easy-chroot/sbin/cpu-perform"
55         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
56         cp -a "src/sbin/qchroot" "$(CURDIR)/debian/easy-chroot/sbin/qchroot"
57         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
58         cp -a "src/sbin/qmount" "$(CURDIR)/debian/easy-chroot/sbin/qmount"
59         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
60         cp -a "src/sbin/qumount" "$(CURDIR)/debian/easy-chroot/sbin/qumount"
61         mkdir -p "$(CURDIR)/debian/easy-chroot/sbin/"
62         cp -a "src/sbin/synchroot" "$(CURDIR)/debian/easy-chroot/sbin/synchroot"
63         mkdir -p "$(CURDIR)/debian/easy-chroot/usr/bin/"
64         cp -a "src/usr/bin/gxmessage" "$(CURDIR)/debian/easy-chroot/usr/bin/gxmessage"
65         mkdir -p "$(CURDIR)/debian/easy-chroot/usr/bin/"
66         cp -a "src/usr/bin/hostwin" "$(CURDIR)/debian/easy-chroot/usr/bin/hostwin"
67         mkdir -p "$(CURDIR)/debian/easy-chroot/usr/bin/"
68         cp -a "src/usr/bin/quserchroot" "$(CURDIR)/debian/easy-chroot/usr/bin/quserchroot"
69         mkdir -p "$(CURDIR)/debian/easy-chroot/etc/sudoers.d/"
70         cp -a "src/etc/sudoers.d/chroot.sudoers" "$(CURDIR)/debian/easy-chroot/etc/sudoers.d/chroot.sudoers"
71
72         # ======================================================
73
74 # Build architecture-independent files here.
75 binary-indep: build install
76 # We have nothing to do by default.
77
78 # Build architecture-dependent files here.
79 binary-arch: build install
80         dh_testdir
81         dh_testroot
82         dh_installchangelogs debian/changelog
83         dh_installdocs
84         dh_installexamples
85 #       dh_install
86 #       dh_installmenu
87 #       dh_installdebconf
88 #       dh_installlogrotate
89 #       dh_installemacsen
90 #       dh_installpam
91 #       dh_installmime
92 #       dh_python
93 #       dh_installinit
94 #       dh_installcron
95 #       dh_installinfo
96         dh_installman
97         dh_link
98         dh_strip
99         dh_compress
100         dh_fixperms
101 #       dh_perl
102 #       dh_makeshlibs
103         dh_installdeb
104 #       dh_shlibdeps
105         dh_gencontrol
106         dh_md5sums
107         dh_builddeb
108
109 binary: binary-indep binary-arch
110 .PHONY: build clean binary-indep binary-arch binary install configure