Added icons.
[emufront] / src / debian / rules
1 #!/usr/bin/make -f
2 APPNAME := emufront
3 builddir:
4         mkdir -p builddir
5
6 builddir/Makefile: builddir
7         cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
8
9 build: build-stamp
10
11 build-stamp: builddir/Makefile  
12         dh_testdir
13         # Add here commands to compile the package.
14         cd builddir && $(MAKE)
15         touch $@
16
17 clean: 
18         dh_testdir
19         dh_testroot
20         rm -f build-stamp
21         # Add here commands to clean up after the build process.
22         rm -rf builddir
23         dh_clean
24 install: build
25         dh_testdir
26         dh_testroot
27         dh_clean -k 
28         dh_installdirs
29
30         # Add here commands to install the package into debian/emufront.
31         cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
32
33 # Build architecture-independent files here.
34 binary-indep: build install
35 # We have nothing to do by default.
36
37 # Build architecture-dependent files here.
38 binary-arch: build install
39         dh_testdir
40         dh_testroot
41         dh_installdocs
42         dh_installexamples
43 #       dh_install
44 #       dh_installmenu
45 #       dh_installdebconf       
46 #       dh_installlogrotate
47 #       dh_installemacsen
48 #       dh_installpam
49 #       dh_installmime
50 #       dh_python
51 #       dh_installinit
52 #       dh_installcron
53 #       dh_installinfo
54         dh_installman
55         dh_link
56 #       dh_strip
57         dh_compress
58         dh_fixperms
59 #       dh_perl
60 #       dh_makeshlibs
61         dh_installdeb
62         dh_shlibdeps
63         dh_gencontrol
64         dh_md5sums
65         dh_builddeb
66
67 binary: binary-indep binary-arch
68 .PHONY: build clean binary-indep binary-arch binary install configure