78940cca43ca25009bf4adfef39286cb99c6caf4
[hermes] / package / debian / hermes.postinst
1 #!/bin/sh
2
3 set -e
4 gconftool-2 -s /apps/maemo/hermes/facebook_app 5916f12942feea4b3247d42a84371112 --type string
5 gconftool-2 -s /apps/maemo/hermes/facebook_secret 19f7538edd96b6870f2da7e84a6390a4 --type string
6 gconftool-2 -s /apps/maemo/hermes/gravatar_email maemohermes@wendt.se --type string
7 gconftool-2 -s /apps/maemo/hermes/gravatar_key b14ec179822b --type string
8 gconftool-2 -s /apps/maemo/hermes/linkedin_key 1et4G-VtmtqNfY7gF8PHtxMOf0KNWl9ericlTEtdKJeoA4ubk4wEQwf8lSL8AnYE --type string
9 gconftool-2 -s /apps/maemo/hermes/linkedin_secret uk--OtmWcxER-Yh6Py5p0VeLPNlDJSMaXj1xfHILoFzrK7fM9eepNo5RbwGdkRo_ --type string
10
11 # Version 0.2.1 changed type of /apps/maemo/hermes/uid
12 OLD_UID=`gconftool-2 -g /apps/maemo/hermes/uid`
13 [ -z "$OLD_UID" ] || gconftool-2 -s /apps/maemo/hermes/uid "$OLD_UID" --type string
14
15 # Hacky fix for NB#136012
16 gconftool-2 -s /desktop/gnome/url-handlers/http/command 'dbus-send --system --type=method_call --dest="com.nokia.osso_browser" --print-reply /com/nokia/osso_browser/request com.nokia.osso_browser.load_url string:"%s"' --type string 
17
18 gtk-update-icon-cache -f /usr/share/icons/hicolor