update debian/changelog
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / minstrel-aziwoqpa.diff
1 --- kernel-power-2.6.28.orig/net/mac80211/rc80211_minstrel.c.orig       2010-11-13 13:20:41.000000000 -0500
2 +++ kernel-power-2.6.28/net/mac80211/rc80211_minstrel.c 2010-11-13 13:46:05.246025157 -0500
3 @@ -228,7 +228,7 @@
4         unsigned int sample_ndx;
5         sample_ndx = SAMPLE_TBL(mi, mi->sample_idx, mi->sample_column);
6         mi->sample_idx++;
7 -       if ((int) mi->sample_idx > (mi->n_rates - 2)) {
8 +       if (mi->n_rates == 1 || (int) mi->sample_idx > (mi->n_rates - 2)) {
9                 mi->sample_idx = 0;
10                 mi->sample_column++;
11                 if (mi->sample_column >= SAMPLE_COLUMNS)