update debian/changelog
[kernel-bfs] / kernel-bfs-2.6.28 / debian / patches / phys_to_page.diff
1 --- kernel-power-2.6.28.orig/arch/arm/include/asm/memory.h      2008-12-24 23:26:37.000000000 +0000
2 +++ kernel-power-2.6.28/arch/arm/include/asm/memory.h   2011-04-18 20:34:23.000000000 +0100
3 @@ -123,6 +123,12 @@
4  #define        __phys_to_pfn(paddr)    ((paddr) >> PAGE_SHIFT)
5  #define        __pfn_to_phys(pfn)      ((pfn) << PAGE_SHIFT)
6  
7 +/*
8 + * Convert a page to/from a physical address
9 + */
10 +#define page_to_phys(page)     (__pfn_to_phys(page_to_pfn(page)))
11 +#define phys_to_page(phys)     (pfn_to_page(__phys_to_pfn(phys)))
12 +
13  #ifndef __ASSEMBLY__
14  
15  /*
16 @@ -293,11 +299,6 @@ static inline __deprecated void *bus_to_
17  #endif /* !CONFIG_DISCONTIGMEM */
18  
19  /*
20 - * For BIO.  "will die".  Kill me when bio_to_phys() and bvec_to_phys() die.
21 - */
22 -#define page_to_phys(page)     (page_to_pfn(page) << PAGE_SHIFT)
23 -
24 -/*
25   * Optional coherency support.  Currently used only by selected
26   * Intel XSC3-based systems.
27   */