Updated patch bt-mice.diff: fix the famous BT headset issue
[kernel-power] / kernel-power-2.6.28 / debian / patches / bt-mice.diff
1 --- a/net/bluetooth/hci_conn.c  2012-01-30 12:53:26.208588006 -0500
2 +++ b/net/bluetooth/hci_conn.c  2012-01-30 12:45:59.891069000 -0500
3 @@ -498,7 +498,7 @@
4         if (test_bit(HCI_RAW, &hdev->flags))
5                 return;
6  
7 -       if (conn->mode != HCI_CM_SNIFF)
8 +       if (conn->mode != HCI_CM_SNIFF || (((conn->dev_class[1]&0x1f) == 0x05) && !conn->power_save))
9                 goto timer;
10  
11         if (!test_and_set_bit(HCI_CONN_MODE_CHANGE_PEND, &conn->pend)) {