Add patch dspbridge_new_api.diff which bring support for CONFIG_BRIDGE_NEW_API
[kernel-power] / kernel-power-2.6.28 / debian / patches / dspbridge_new_api.diff
1 --- kernel-power-2.6.28/drivers/dsp/bridge/Makefile     2011-09-26 21:52:59.000000000 +0100
2 +++ kernel-power-2.6.28.new/drivers/dsp/bridge/Makefile 2011-09-24 16:39:00.000000000 +0100
3 @@ -25,6 +25,11 @@
4  ccflags-y += -DGT_TRACE
5  endif
6  
7 +#New API
8 +ifeq ($(CONFIG_BRIDGE_NEW_API),y)
9 +ccflags-y += -DCONFIG_BRIDGE_NEW_API
10 +endif
11 +
12  #Machine dependent
13  ccflags-y += -D_TI_ -D_DB_TIOMAP -DTMS32060 \
14                 -DTICFG_PROC_VER -DTICFG_EVM_TYPE -DCHNL_SMCLASS \
15 --- kernel-power-2.6.28/drivers/dsp/bridge/Kconfig      2011-09-26 21:48:34.000000000 +0100
16 +++ kernel-power-2.6.28.new/drivers/dsp/bridge/Kconfig  2011-09-24 17:03:05.000000000 +0100
17 @@ -45,3 +45,9 @@
18           Enable notifications to registered clients on the event of power errror
19           trying to suspend bridge driver. Say Y, to signal this event as a fatal
20           error, this will require a bridge restart to recover.
21 +
22 +config BRIDGE_NEW_API
23 +       bool "DSP Bridge new API"
24 +       depends on MPU_BRIDGE
25 +       help
26 +         Say Y to enable Bridge new API(ioctl codes)