version26
[kernel-power] / kernel-power-2.6.28 / debian / patches / gethercharge.diff
1 --- kernel-power-2.6.28.orig/drivers/usb/gadget/ether.c
2 +++ kernel-power-2.6.28/drivers/usb/gadget/ether.c
3 @@ -241,7 +241,8 @@
4         .bind                   = rndis_do_config,
5         .bConfigurationValue    = 2,
6         /* .iConfiguration = DYNAMIC */
7 -       .bmAttributes           = USB_CONFIG_ATT_SELFPOWER,
8 +       .bmAttributes   = USB_CONFIG_ATT_ONE,
9 +       .bMaxPower      = 250, /* 500mA */
10  };
11  
12  /*-------------------------------------------------------------------------*/
13 @@ -269,7 +270,8 @@
14         .bind                   = eth_do_config,
15         .bConfigurationValue    = 1,
16         /* .iConfiguration = DYNAMIC */
17 -       .bmAttributes           = USB_CONFIG_ATT_SELFPOWER,
18 +       .bmAttributes   = USB_CONFIG_ATT_ONE,
19 +       .bMaxPower      = 250, /* 500mA */
20  };
21  
22  /*-------------------------------------------------------------------------*/