e9875636f3de28effc82c69a47e3b041611b26c3
[maemo-efl] / trunk / e_dbus / debian / patches / 02-dbus-signatures-h.diff
1 diff -uN --exclude='Makefile*' dbus/dbus-signature.h dbus-dev/dbus-signature.h
2 --- e_dbus/src/lib/dbus/dbus-signature.h        1969-12-31 21:00:00.000000000 -0300
3 +++ e_dbus/src/lib/dbus/dbus-signature.h        2007-09-19 18:16:16.000000000 -0300
4 @@ -0,0 +1,74 @@
5 +/* -*- mode: C; c-file-style: "gnu" -*- */
6 +/* dbus-signatures.h utility functions for D-BUS types
7 + *
8 + * Copyright (C) 2005 Red Hat Inc.
9 + *
10 + * Licensed under the Academic Free License version 2.1
11 + * 
12 + * This program is free software; you can redistribute it and/or modify
13 + * it under the terms of the GNU General Public License as published by
14 + * the Free Software Foundation; either version 2 of the License, or
15 + * (at your option) any later version.
16 + *
17 + * This program is distributed in the hope that it will be useful,
18 + * but WITHOUT ANY WARRANTY; without even the implied warranty of
19 + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
20 + * GNU General Public License for more details.
21 + * 
22 + * You should have received a copy of the GNU General Public License
23 + * along with this program; if not, write to the Free Software
24 + * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
25 + *
26 + */
27 +#ifndef DBUS_SIGNATURES_H
28 +#define DBUS_SIGNATURES_H
29 +
30 +#define DBUS_INSIDE_DBUS_H 1
31 +
32 +#include <dbus/dbus-macros.h>
33 +#include <dbus/dbus-types.h>
34 +#include <dbus/dbus-errors.h>
35 +
36 +DBUS_BEGIN_DECLS
37 +
38 +/**
39 + * DBusSignatureIter struct; contains no public fields 
40 + */
41 +typedef struct
42 +{ 
43 +  void *dummy1;         /**< Don't use this */
44 +  void *dummy2;         /**< Don't use this */
45 +  dbus_uint32_t dummy8; /**< Don't use this */
46 +  int dummy12;           /**< Don't use this */
47 +  int dummy17;           /**< Don't use this */
48 +} DBusSignatureIter;
49 +
50 +void            dbus_signature_iter_init             (DBusSignatureIter       *iter,
51 +                                                     const char              *signature);
52 +
53 +int             dbus_signature_iter_get_current_type (const DBusSignatureIter *iter);
54 +
55 +char *          dbus_signature_iter_get_signature    (const DBusSignatureIter *iter);
56 +
57 +int             dbus_signature_iter_get_element_type (const DBusSignatureIter *iter);
58 +
59 +dbus_bool_t     dbus_signature_iter_next             (DBusSignatureIter       *iter);
60 +
61 +void            dbus_signature_iter_recurse          (const DBusSignatureIter *iter,
62 +                                                     DBusSignatureIter       *subiter);
63 +
64 +dbus_bool_t     dbus_signature_validate              (const char       *signature,
65 +                                                     DBusError        *error);
66 +
67 +dbus_bool_t     dbus_signature_validate_single       (const char       *signature,
68 +                                                     DBusError        *error);
69 +
70 +dbus_bool_t     dbus_type_is_basic                   (int            typecode);
71 +dbus_bool_t     dbus_type_is_container               (int            typecode);
72 +dbus_bool_t     dbus_type_is_fixed                   (int            typecode);
73 +
74 +DBUS_END_DECLS
75 +
76 +#undef DBUS_INSIDE_DBUS_H
77 +
78 +#endif /* DBUS_MESSAGE_H */
79 diff -uN --exclude='Makefile*' dbus/e_dbus_object.c dbus-dev/e_dbus_object.c
80 --- e_dbus/src/lib/dbus/e_dbus_object.c 2007-09-05 11:40:53.000000000 -0300
81 +++ e_dbus/src/lib/dbus/e_dbus_object.c 2007-09-19 18:15:00.000000000 -0300
82 @@ -5,6 +5,8 @@
83  #include <stdlib.h>
84  #include <string.h>
85  
86 +#include "dbus-signature.h"
87 +
88  static E_DBus_Interface *introspectable_interface = NULL;
89  static E_DBus_Interface *properties_interface = NULL;
90