Making things a bit more readable.
[maemo-efl] / trunk / ecore / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5
6 DEB_CONFIGURE_EXTRA_FLAGS :=  --disable-ecore-fb                        \
7                                                           --disable-ecore-directfb              \
8                                                           --disable-ecore-evas-gl               \
9                                                           --disable-ecore-evas-dfb              \
10                                                           --disable-ecore-evas-xrender  \
11                                                           --disable-ecore-evas-fb               \
12                                                           --disable-openssl                             \
13                                                           --disable-abstract-sockets    \
14                                                           --disable-ecore-ipc                   \
15                                                           --disable-ecore-dbus                  \
16                                                           --disable-ecore-config                \
17                                                           --disable-ecore-desktop               \
18                                                           --disable-ecore-sdl                   \
19                                                           --disable-ecore-evas-sdl              \
20                                                           --enable-ecore-evas-x11-16
21
22 DEB_CONFIGURE_SCRIPT_ENV += CURL_LIBS="-lcurl"
23
24 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
25
26 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
27         CFLAGS := $(CFLAGS) -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
28 endif
29