c04cdca1dc774342c5cf5328b4c32342b53363f6
[maemo-efl] / trunk / edje / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5
6 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
7
8 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
9         CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
10         ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
11                 CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
12         endif
13         ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
14                 CFLAGS += -mcpu=arm926ej-s
15         endif
16 endif
17