rules: use BUILD_DEB_OPTIONS for n770 and n8x0 variants
[maemo-efl] / trunk / edje / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5 include /usr/share/cdbs/1/rules/patchsys-quilt.mk
6
7 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
8
9 CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -I/usr/X11R6/include
10                                                                                                                   
11 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
12         CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
13         ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
14                 CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
15         endif
16         ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
17                 CFLAGS += -mcpu=arm926ej-s
18         endif
19 endif
20