d7cc0629aa7b67536e0faab4e2593052fead80e6
[maemo-efl] / trunk / eet / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5 include /usr/share/cdbs/1/rules/patchsys-quilt.mk
6
7 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
8
9 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
10         CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
11         ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
12                 CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
13         endif
14         ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
15                  CFLAGS += -mcpu=arm926ej-s
16         endif
17 endif
18