6230be93d32916a911945bbf29bdf0ad7917de01
[maemo-efl] / trunk / imlib2 / debian / rules
1 #!/usr/bin/make -f
2
3 include /usr/share/cdbs/1/rules/debhelper.mk
4 include /usr/share/cdbs/1/class/autotools.mk
5 include /usr/share/cdbs/1/rules/simple-patchsys.mk
6
7 DEB_CONFIGURE_EXTRA_FLAGS := --disable-mmx              \
8                                                          --disable-amd64        \
9                                                          --without-gif          \
10                                                          --without-id3
11
12 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
13
14 CFLAGS += -I/usr/X11R6/include
15
16 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
17         CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
18         ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
19                 CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
20         endif
21         ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
22                 CFLAGS += -mcpu=arm926ej-s
23         endif
24 endif
25