Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / debian / patches / 0005-tagreadbin-don-t-try-to-guess-codec-tag-from-NULL-ca.patch
1 From 09628395d26c18dab61914d190821622e6555929 Mon Sep 17 00:00:00 2001
2 From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim.muller@collabora.co.uk>
3 Date: Tue, 1 Sep 2009 15:29:24 +0100
4 Subject: [PATCH] tagreadbin: don't try to guess codec tag from NULL caps in
5  the tagsink
6
7 Fixes crash when the caps are NULL for some reason (NB #135291).
8 ---
9  gst/tagreading/gsttagsink.c |    3 ++-
10  1 files changed, 2 insertions(+), 1 deletions(-)
11
12 diff --git a/gst/tagreading/gsttagsink.c b/gst/tagreading/gsttagsink.c
13 index 3741897..6de9626 100644
14 --- a/gst/tagreading/gsttagsink.c
15 +++ b/gst/tagreading/gsttagsink.c
16 @@ -732,7 +732,8 @@ gst_tag_sink_stream_analyse_tags (GstTagSink * tsink, GstTagSinkStream * stream)
17    }
18  
19    /* if we don't have a codec tag for this stream, add one based on the caps */
20 -  if (!gst_tag_read_utils_list_has_codec_tag (stream->stream_tags)) {
21 +  if (stream->caps != NULL &&
22 +      !gst_tag_read_utils_list_has_codec_tag (stream->stream_tags)) {
23      gst_tag_read_utils_add_codec_tag_from_caps (stream->stream_tags,
24          stream->caps);
25    }