Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / debian / patches / 0027-tests-xmp-New-tests-for-the-Iptc4xmpExt-tags.patch
1 From 20e5394e98aa25abb17838cc5d70fa1035c5fd1d Mon Sep 17 00:00:00 2001
2 From: Thiago Santos <thiago.sousa.santos@collabora.co.uk>
3 Date: Tue, 19 Apr 2011 08:41:53 -0300
4 Subject: [PATCH] tests: xmp: New tests for the Iptc4xmpExt tags
5
6 ---
7  tests/check/libs/tag.c |   15 +++++++++++----
8  1 files changed, 11 insertions(+), 4 deletions(-)
9
10 diff --git a/tests/check/libs/tag.c b/tests/check/libs/tag.c
11 index c963ce5..555cdb8 100644
12 --- a/tests/check/libs/tag.c
13 +++ b/tests/check/libs/tag.c
14 @@ -913,12 +913,13 @@ tag_list_equals (GstTagList * taglist, GstTagList * taglist2)
15  }
16  
17  static void
18 -do_xmp_tag_serialization_deserialization (GstTagList * taglist)
19 +do_xmp_tag_serialization_deserialization (GstTagList * taglist,
20 +    const gchar ** schemas)
21  {
22    GstTagList *taglist2;
23    GstBuffer *buf;
24  
25 -  buf = gst_tag_list_to_xmp_buffer (taglist, TRUE);
26 +  buf = gst_tag_list_to_xmp_buffer_full (taglist, TRUE, schemas);
27    taglist2 = gst_tag_list_from_xmp_buffer (buf);
28  
29    tag_list_equals (taglist, taglist2);
30 @@ -935,7 +936,7 @@ do_simple_xmp_tag_serialization_deserialization (const gchar * gsttag,
31  
32    gst_tag_list_add_value (taglist, GST_TAG_MERGE_REPLACE, gsttag, value);
33  
34 -  do_xmp_tag_serialization_deserialization (taglist);
35 +  do_xmp_tag_serialization_deserialization (taglist, NULL);
36    gst_tag_list_free (taglist);
37  }
38  
39 @@ -1122,13 +1123,19 @@ GST_END_TEST;
40  
41  GST_START_TEST (test_xmp_compound_tags)
42  {
43 +  const gchar *schemas[] = { "Iptc4xmpExt", NULL };
44    GstTagList *taglist = gst_tag_list_new ();
45  
46    gst_tag_list_add (taglist, GST_TAG_MERGE_APPEND, GST_TAG_KEYWORDS, "k1",
47        GST_TAG_KEYWORDS, "k2", GST_TAG_TITLE, "title", GST_TAG_KEYWORDS, "k3",
48        NULL);
49 +  do_xmp_tag_serialization_deserialization (taglist, NULL);
50 +  gst_tag_list_free (taglist);
51  
52 -  do_xmp_tag_serialization_deserialization (taglist);
53 +  taglist = gst_tag_list_new ();
54 +  gst_tag_list_add (taglist, GST_TAG_MERGE_APPEND, GST_TAG_GEO_LOCATION_COUNTRY,
55 +      "Brazil", GST_TAG_GEO_LOCATION_CITY, "Campina Grande", NULL);
56 +  do_xmp_tag_serialization_deserialization (taglist, schemas);
57    gst_tag_list_free (taglist);
58  }
59