Install osm base tile in the cache dir.
[marble] / packaging / debian / marble.postinst
1 #!/bin/sh
2
3 set -e
4
5 if [ "$1" != "configure" ]
6 then
7   exit 0
8 fi
9
10 ### Change old default values to new default values
11
12 CONFIG_FILE="/home/user/.config/kde.org/Marble Desktop Globe.conf"
13 if test -e "${CONFIG_FILE}"
14 then
15   sed -i \
16   -e 's/^sideBar=true$/sideBar=false/' \
17   -e 's/^volatileTileCacheLimit=30$/volatileTileCacheLimit=6/' \
18   -e 's/^projection=0$/projection=2/' \
19   -e '/^distanceUnit=/d' \
20   -e 's/^persistentTileCacheLimit=300$/persistentTileCacheLimit=0/' \
21   "${CONFIG_FILE}"
22   chown user:users "${CONFIG_FILE}"
23 fi
24
25 ### Migrate cached openstreetmap tiles to shared directory
26
27 # The OSM tile download location in Marble 1.0.x and earlier
28 OSM_DIR_10="/home/user/MyDocs/.local/share/marble/maps/earth/openstreetmap"
29
30 # The OSM tile download location in Marble 1.1 and later
31 OSM_DIR_11="/home/user/MyDocs/.maps/OpenStreetMap I"
32
33 # The OSM base path
34 OSM_DIR_BASE="/opt/marble/share/marble/data/maps/earth/openstreetmap"
35
36 # The OSM theme .dgml file
37 OSM_DGML="${OSM_DIR_BASE}/openstreetmap.dgml"
38
39 # A file used as a flag to indicate a previous migration
40 MIGRATED="${OSM_DIR_10}/.migrated"
41
42 # Verify we have the .dgml file and can write to it (required)
43 test -w "${OSM_DGML}" || { echo "DGML file ${OSM_DGML} not existant/writable."; exit 1; }
44
45 # Check whether the tiles were previously migrated. In that case there's nothing to do
46 test -e "${MIGRATED}" && exit 0
47
48 # If the migration has to move files, ask the user to skip it since it can
49 # take some minutes to finish
50
51 test -e "${OSM_DIR_10}" && test -e "${OSM_DIR_11}" && { maemo-confirm-text "Enable OpenStreetMap Data Sharing" /opt/marble/share/marble/data/migration-warning.txt || exit 0; }
52
53 # Tile migration
54 mkdir -p "${OSM_DIR_11}"
55 if test -d "${OSM_DIR_10}"
56 then
57     # Cached tiles from an old Marble installation exist and must be migrated
58     for x in ${OSM_DIR_10}/[0-9]*
59     do
60         test -e "${x}" || continue
61         dx="$(basename ${x})"
62         if test -e "${OSM_DIR_11}/${dx}"
63         then
64             # Tiles /x/ were downloaded both in Marble and another application
65             for y in ${x}/[0-9]*
66             do
67                 test -e "${y}" || continue
68                 dy="$(basename ${y})"
69                 target="${OSM_DIR_11}/${dx}/${dy}/"
70                 if test -e "${target}"
71                 then
72                     # Tiles /x/y/ were downloaded both in Marble and another application. Move each /x/y/z
73                     mv "${y}"/[0-9]*.png "${target}"
74                     rmdir "${y}" || true
75                 else
76                     # Target dir does not exist yet, so we can move it over (much quicker)
77                     mv "${y}" "${OSM_DIR_11}/${dx}"
78                 fi
79             done
80             rmdir "${x}" || true
81         else
82             # Target does not exist yet, so we can move it over (much quicker)
83             mv "${x}" "${OSM_DIR_11}/"
84         fi
85     done
86 fi
87
88 # Delete now empty directory
89 test -d "${OSM_DIR_10}/" && rmdir "${OSM_DIR_10}/" || true
90
91 # If files are left in the old directory, leave a flag to avoid running 
92 # the migration again. This only happens if the user created custom files in
93 # the OSM cache directory
94 test -d "${OSM_DIR_10}/" && touch "${MIGRATED}"
95
96 # Finally, change the download location in the .dgml file. Also needed for new installations
97 sed -i "s@<sourcedir format=\"PNG\"> earth/openstreetmap </sourcedir>@<sourcedir format=\"PNG\"> ${OSM_DIR_11} </sourcedir>@" "${OSM_DGML}"
98
99 # Copy the base tile to the right place.
100 mkdir -p "${OSM_DIR_11}/0/0"
101 cp "${OSM_DIR_BASE}/0/0/0.png" "${OSM_DIR_11}/0/0/"
102
103 exit 0