Don't skip texture layers without base tiles, try downloading them.
[marble] / packaging / debian / patches / download-basetiles.diff
1 Index: src-fremantle/src/lib/MarbleMap.cpp
2 ===================================================================
3 --- src-fremantle.orig/src/lib/MarbleMap.cpp    2011-12-04 10:51:08.000000000 +0100
4 +++ src-fremantle/src/lib/MarbleMap.cpp 2011-12-04 10:51:31.000000000 +0100
5 @@ -870,10 +870,9 @@
6                      delete tileCreatorDlg;
7                  }
8  
9 -                if ( TileLoader::baseTilesAvailable( *texture ) ) {
10 -                    textures.append( texture );
11 -                } else {
12 -                    qWarning() << "Base tiles for" << sourceDir << "not available. Skipping.";
13 +                textures.append( texture );
14 +                if ( !TileLoader::baseTilesAvailable( *texture ) ) {
15 +                    qWarning() << "Base tiles for" << sourceDir << "not available.";
16                  }
17              }
18          }