Added gtk+ recipe for maemo-gtk changes
[oespirit1] / gtk+ / gtk+_2.12.12.bb
1 # 01/06/09 15:33:17  Kirtika B Ruchandani <kirtibr@gmail.com> 
2 # Temporary recipe for Maemo GTK for testing 
3 # Copied over from the 2.12.11 bb file and modified
4
5 require gtk+.inc
6
7 PR = "r1"
8
9 DEPENDS += "cairo"
10
11 DEFAULT_PREFERENCE = 1 
12
13 S="${WORKDIR}/gtk+2.0-2.12.12"
14
15 #FIXME : Patches currently used are only to get the build working. After testing on the device,
16 #uncomment the required patches
17
18 SRC_URI = "http://repository.maemo.org/pool/fremantle/free/g/gtk+2.0/gtk+2.0_${PV}-1maemo12+0m5.tar.gz \
19            file://gtk+2.0-2.12.12/mer-changes.patch;patch=1 \
20            file://gtk+2.0-2.12.12/mkinstalldirs \
21            file://gtk+2.0-2.12.12/no-demos.patch;patch=1 "
22 #          file://gtk+2.0-2.12.12/xsettings.patch;patch=1 \
23 #          file://gtk+2.0-2.12.12/run-iconcache.patch;patch=1 \
24 #          file://gtk+2.0-2.12.12/hardcoded_libtool.patch;patch=1 \
25 #          file://gtk+2.0-2.12.12/cellrenderer-cairo.patch;patch=1;pnum=0 \
26 #           file://gtk+2.0-2.12.12/entry-cairo.patch;patch=1;pnum=0 \
27 #           file://gtk+2.0-2.12.12/toggle-font.diff;patch=1;pnum=0 \
28 #           file://gtk+2.0-2.12.12/scrolled-placement.patch;patch=1;pnum=0 \
29 # temporary
30 #           file://gtk+2.0-2.12.12/gtklabel-resize-patch;patch=1 \
31 #           file://gtk+2.0-2.12.12/menu-deactivate.patch;patch=1 \
32 #           file://gtk+2.0-2.12.12/combo-arrow-size.patch;patch=1;pnum=0 \
33 # die die die
34 #           file://gtk+2.0-2.12.12/pangoxft2.10.6.diff;patch=1"
35
36 EXTRA_OECONF = "--with-libtiff --disable-xkb --enable-display-migration --disable-gtk-doc --with-maemo=yes --with-libpng --with-libjpeg --with-x "
37
38 LIBV = "2.10.0"
39
40 PACKAGES_DYNAMIC = "gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
41
42 do_configure_prepend(){
43     touch gtk-doc.make
44 }
45
46 python populate_packages_prepend () {
47         import os.path
48
49         prologue = bb.data.getVar("postinst_prologue", d, 1)
50
51         gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
52         loaders_root = os.path.join(gtk_libdir, 'loaders')
53         immodules_root = os.path.join(gtk_libdir, 'immodules')
54         printmodules_root = os.path.join(gtk_libdir, 'printbackends');
55
56         do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', prologue + 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
57         do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', prologue + 'gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules')
58         do_split_packages(d, printmodules_root, '^libprintbackend-(.*)\.so$', 'gtk-printbackend-%s', 'GTK printbackend module for %s')
59
60         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
61                 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
62 }