Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / hildon-icons_2.1.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Hildon Icons"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "unknown"
7 SECTION = "x11"
8
9 SRC_URI = "http://ftp.de.debian.org/debian/pool/main/h/${PN}/${PN}_${PV}.debian.orig.tar.gz  \
10            file://hildon-icons/mer-changes.patch;patch=1"
11
12 S = "${WORKDIR}/${PN}-${PV}.debian.orig"
13
14 PACKAGES = "${PN}"
15
16 FILES_${PN} = "${datadir}/icons/*"
17
18 inherit gtk-icon-cache
19
20 do_install(){
21     install -d ${D}${datadir}/icons ${D}${datadir}/icons/hildon
22     install -m 0755  ${S}/index.theme ${D}${datadir}/icons/hildon
23         sh ${S}/install-theme.sh ${S}/icons ${D}${datadir}/icons/hildon
24         sh ${S}/make-mime-symlinks.sh ${D}${datadir}/icons/hildon/scalable
25 }