Reverting all the dbus related commits (sigh) from 27th July and fixing a QA issue...
[oespirit1] / marquee-plugins_0.22.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Plugins for the hildon marquee, with Mer patches: Part of a messy maemo+mer+ubuntu mixed UI"
5 HOMEPAGE = "unknown (Ubuntu Mobile home page)"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "ui"
8 DEPENDS = "hildon-desktop dbus-glib"
9 PR = "r0"
10
11 SRC_URI = "http://mirror.anl.gov/pub/ubuntu/pool/universe/m/${PN}/${PN}_${PV}.orig.tar.gz \
12            file://marquee-plugins/mer-changes.patch;patch=1"
13
14
15 inherit autotools pkgconfig
16
17 # A test workaround to fix the "No GNU_HASH"
18 # in elf binary issue            
19 TARGET_CC_ARCH += "${LDFLAGS}"
20
21
22 do_configure_prepend(){
23     for i in `grep -r -l Werror *`;
24     do sed -i s:-Werror::g $i;
25         done;
26 }
27
28 FILES_${PN} =+ "/usr/lib/hildon-desktop/* "