Make it bitbake-able without the -b switch by correcting DEPENDS variables
[oespirit1] / marquee-plugins_0.22.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Plugins for the hildon marquee, with Mer patches: Part of a messy maemo+mer+ubuntu mixed UI"
5 HOMEPAGE = "unknown (Ubuntu Mobile home page)"
6 LICENSE = "GNU Lesser General Public License-version 2.1"
7 SECTION = "ui"
8 DEPENDS = "hildon-desktop dbus-glib"
9 PR = "r0"
10
11 SRC_URI = "http://mirror.anl.gov/pub/ubuntu/pool/universe/m/${PN}/${PN}_${PV}.orig.tar.gz \
12            file://marquee-plugins/mer-changes.patch;patch=1"
13
14
15 inherit autotools pkgconfig
16
17 do_configure_prepend(){
18     for i in `grep -r -l Werror *`;
19     do sed -i s:-Werror::g $i;
20         done;
21 }
22
23 FILES_${PN} =+ "/usr/lib/hildon-desktop/* "