Make it bitbake-able without the -b switch by correcting DEPENDS variables
[oespirit1] / osso-af-startup_1.79.bb
1 # Copyright (C) 2009 Kirtika Ruchandani <kirtibr@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "Application framework startup scripts, services and base-apps"
5 HOMEPAGE = "http://maemo.org"
6 LICENSE = "GPLv2"
7 SECTION = "base"
8 DEPENDS = "osso-af-utils  osso-core-config dbus"
9
10 PR = "r2"
11
12 SRC_URI = "http://repository.maemo.org/pool/fremantle/free/o/${PN}/${PN}_${PV}-2+0m5.tar.gz"
13
14 inherit pkgconfig 
15
16
17 do_install () {
18     install -m 0755 -d ${D}${sysconfdir}/osso-af-init ${D}${sysconfdir}/init.d ${D}${sysconfdir}/sudoers.d
19     install -m 0755 ${S}/top-scripts/* ${D}${sysconfdir}/init.d/
20     install -m 0755 ${S}/services/* ${D}${sysconfdir}/osso-af-init/
21     install -m 0644 ${S}/osso-af-startup.sudoers ${D}${sysconfdir}/sudoers.d/osso-af-startup.sudoers
22 }
23
24 PACKAGES = "${PN}"
25
26 FILES_${PN} = "/etc/osso-af-init/* \
27                /etc/sudoers.d/*    \
28                /etc/init.d/* "