Fixed issue with reading signal level. Updated changelog. Possibly fixed icon in...
[oldschool] / oldschool-0.9.0 / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18         CFLAGS += -O0
19 else
20         CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25         dh_testdir
26         # Add here commands to configure the package.
27
28         touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp 
34         dh_testdir
35
36         # Add here commands to compile the package.
37         #$(MAKE)
38         #docbook-to-man debian/oldschool.sgml > oldschool.1
39
40         #touch $@
41         touch build-stamp
42
43 clean:
44         dh_testdir
45         dh_testroot
46         rm -f build-stamp configure-stamp
47
48         # Add here commands to clean up after the build process.
49         #commented out by rbm
50         #-$(MAKE) clean
51
52         dh_clean 
53
54 install: build
55         dh_testdir
56         dh_testroot
57         dh_clean -k 
58         dh_installdirs
59
60         # Add here commands to install the package into debian/oldschool.
61         #commented out by rbm
62         #$(MAKE) DESTDIR=$(CURDIR)/debian/oldschool install
63         mkdir -p "$(CURDIR)/debian/oldschool/"
64
65         mkdir -p "$(CURDIR)/debian/oldschool/opt/oldschool/"
66         cp -a "src/opt/oldschool/n900_levels.py" "$(CURDIR)/debian/oldschool/opt/oldschool/n900_levels.py"
67         mkdir -p "$(CURDIR)/debian/oldschool/opt/oldschool/"
68         cp -a "src/opt/oldschool/old_school.py" "$(CURDIR)/debian/oldschool/opt/oldschool/old_school.py"
69         mkdir -p "$(CURDIR)/debian/oldschool/opt/oldschool/"
70         cp -a "src/opt/oldschool/old_school_bg.jpg" "$(CURDIR)/debian/oldschool/opt/oldschool/old_school_bg.jpg"
71         mkdir -p "$(CURDIR)/debian/oldschool/usr/share/applications/hildon/"
72         cp -a "src/usr/share/applications/hildon/oldschool.desktop" "$(CURDIR)/debian/oldschool/usr/share/applications/hildon/oldschool.desktop"
73         mkdir -p "$(CURDIR)/debian/oldschool/usr/share/icons/hicolor/scalable/hildon/"
74         cp -a "src/usr/share/icons/hicolor/scalable/hildon/old_school_icon.png" "$(CURDIR)/debian/oldschool/usr/share/icons/hicolor/scalable/hildon/old_school_icon.png"
75         mkdir -p "$(CURDIR)/debian/oldschool/usr/share/icons/hicolor/48x48/hildon/"
76         cp -a "src/usr/share/icons/hicolor/48x48/hildon/old_school_icon.png" "$(CURDIR)/debian/oldschool/usr/share/icons/hicolor/48x48/hildon/old_school_icon.png"
77
78
79 # Build architecture-independent files here.
80 binary-indep: build install
81 # We have nothing to do by default.
82
83 # Build architecture-dependent files here.
84 binary-arch: build install
85         dh_testdir
86         dh_testroot
87         dh_installchangelogs 
88         dh_installdocs
89         dh_installexamples
90 #       dh_install
91 #       dh_installmenu
92 #       dh_installdebconf       
93 #       dh_installlogrotate
94 #       dh_installemacsen
95 #       dh_installpam
96 #       dh_installmime
97 #       dh_python
98 #       dh_installinit
99 #       dh_installcron
100 #       dh_installinfo
101         dh_installman
102         dh_link
103         dh_strip
104         dh_compress
105         dh_fixperms
106 #       dh_perl
107 #       dh_makeshlibs
108         dh_installdeb
109         dh_shlibdeps
110         dh_gencontrol
111         dh_md5sums
112         dh_builddeb
113
114 binary: binary-indep binary-arch
115 .PHONY: build clean binary-indep binary-arch binary install configure