Debian lenny version packages
[pkg-perl] / deb-src / dh-make-perl / dh-make-perl-0.47 / debian / rules
1 #!/usr/bin/make -f
2 #-*- makefile -*-
3 # Made with the aid of dh_make, by Craig Small
4 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
5 # Some lines taken from debmake, by Christoph Lameter.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 INST=$(CURDIR)/debian/dh-make-perl
11
12 build: build-stamp
13 build-stamp:
14         dh_testdir
15
16         # Add here commands to compile the package.
17         pod2man --center debian dh-make-perl > dh-make-perl.1
18
19         touch build-stamp
20
21 clean:
22         dh_testdir
23         dh_testroot
24         rm -f build-stamp
25
26         # Add here commands to clean up after the build process.
27         @for i in Strange-0.1 Strange-2.1; do\
28                 if test -d "$$i/debian"; then \
29                         cd $$i; \
30                         debian/rules clean; \
31                         cd ..; \
32                         rm -rf $$i/debian; \
33                 fi \
34         done
35
36         dh_clean dh-make-perl.1 $(wildcard *.changes) $(wildcard *.deb) $(wildcard *.gz)
37
38 install:
39         dh_testdir
40         dh_testroot
41         dh_clean -k
42         dh_installdirs
43
44         # Add here commands to install the package into debian/tmp.
45         #$(MAKE) install DESTDIR=`pwd`/debian/tmp
46         mkdir -p $(INST)/usr/bin
47         mkdir -p $(INST)/usr/share/dh-make-perl
48         cp dh-make-perl $(INST)/usr/bin
49         cp rules* $(INST)/usr/share/dh-make-perl
50         cp overrides $(INST)/usr/share/dh-make-perl
51
52
53 # Build architecture-independent files here.
54 binary-arch: build install
55 # We have nothing to do by default.
56
57 # Build architecture-dependent files here.
58 binary-indep: build install
59         dh_testdir
60         dh_testroot
61         dh_installdocs README
62         dh_installman dh-make-perl.1
63         dh_installchangelogs
64         dh_compress
65         dh_fixperms
66         dh_installdeb
67         dh_perl 
68         dh_gencontrol
69         dh_md5sums
70         dh_builddeb
71
72 source diff:
73         @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
74
75 binary: binary-indep binary-arch
76 .PHONY: build clean binary-indep binary-arch binary